Olá pessoal!

A função índice permite buscar em intervalo dados, informando a linha e coluna. Há duas formas de aplicar esta função: Forma Matricial e Forma de Referência.

Vamos exemplificar primeiramente a forma matricial.

Forma Matricial

A forma matricial retorna o valor de um elemento em uma tabela ou matriz através de valores informados nos índices de linha e coluna.

No exemplo a seguir vamos aplicar esta forma.

Neste exemplo vamos descobrir um valor em uma tabela informando a posição da linha e coluna.

A sintaxe da fórmula é:

ÍNDICE(matriz, núm_linha; [núm_coluna])

Siga os passos para aplicar a fórmula corretamente.

Clique na célula F9, é nesta célula que aparecerá o resultado.

Digite a fórmula: =ÍNDICE(

Selecione a tabela com os dados.

 

Pressione ponto e vírgula e clique na célula onde será digitada a linha.

Clique na célula F7.

Pressione ponto e vírgula novamente e clique na célula onde será digitado a coluna.

Clique na célula F9.

Feche o parêntese e pressione ENTER.

A fórmula deverá ficar assim:

=ÍNDICE(A1:C13;F7;G7)

Veja o resultado:

Basta digitar uma linha e uma coluna que o valor será retornado.

Repare que o valo retornado foi Sul, pois pedimos que o valor retornado deveria estar na 4ª linha e 2ª na coluna.

 

 

Forma de Referência

A forma de referência permite executar a função índice com mais de uma tabela de dados como referência.

Vamos utilizar o exemplo abaixo para entendermos melhor.

Neste exemplo temos duas tabelas de dados.

Vamos fazer a pesquisa em 2 intervalos diferentes, informando a linha, coluna e área.

Clique na célula F9.

Digite a fórmula: = ÍNDICE((

Obs: Repare que abrimos 2 parênteses para a função índice, pois precisamos informar mais de uma tabela.

Selecione a primeira tabela.

Pressione ponto e vírgula e selecione a outra tabela.

Leia Também:   Como proteger arquivos do Word, Excel e PowerPoint contra alterações

Como esta é a última tabela, feche o parêntese.

Pressione ponto e vírgula e clique na célula onde deverá ser digitada a linha.

Clique na célula F7.

Pressione ponto e vírgula e selecione a célula onde deverá ser digitado a coluna.

Clique na célula G7.

Pressione ponto e vírgula e clique na célula onde deverá ser digitada a área.

 

Feche o parêntese.

A fórmula deverá ficar da seguinte maneira.

=ÍNDICE((A2:C9;A12:C16);F7;G7;H7)

Digite agora uma linha uma coluna e uma área, lembrando que a área corresponde a tabela onde deseja pesquisar os dados.

Veja:

 

Repare que a área digitada foi 1, sendo assim os dados pesquisados estão na primeira tabela.

Altere a área digitando 2, o resultado será outro.

O resultado foi diferente pois a área escolhida foi a área 2 ou seja a tabela 2.

Até a próxima dica!