Olá pessoal!

Na dica de hoje vou demonstrar como utilizar o controle caixa de seleção do Excel. A caixa de seleção permite ativar e desativar um valor, este objeto pode ser utilizado para diversos modelos de planilhas.

Podemos ter em uma mesma planilha diversas caixas de seleção, que podem ser selecionadas ao mesmo tempo.

Para entendermos melhor como aplicar este objeto, utilizaremos o exemplo abaixo:

Neste exemplo vamos calcular o valor à pagar acrescentando um valor de frete, toda vez que selecionarmos a caixa de seleção.

Para inserir a caixa de seleção e outros controles, devemos primeiramente habilitar a guia Desenvolvedor.

Para isso, clique na guia Arquivo e clique em Opções.


Clique em Personalizar Faixa de Opções.

Selecione a guia Desenvolvedor.

Clique em Ok.

Vamos agora inserir a caixa de seleção.

Clique na guia Desenvolvedor.

Clique no botão Inserir.

Clique na caixa de seleção.

Clique e arraste para desenhar o objeto na planilha.

Clique com o botão direito do mouse na caixa de seleção.

Clique em editar texto.

Altere o texto para Frete.

Agora precisamos configurar a caixa de seleção.

Clique novamente com o botão direito do mouse sobre a caixa e clique em Formatar Controle.

Na próxima janela devemos configurar um vínculo de célula para o objeto, neste exemplo vou escolher a célula A1.

Obs: Esta célula não poderá ser utilizada para outro processo, deverá ficar limitada apenas ao vínculo da caixa de seleção.

Clique em Ok.

A caixa está configurada, selecione a caixa de seleção, aparecerá na célula A1 o valor VERDADEIRO.

Ao desmarcar aparece FALSO.

Veja:

 

Agora precisamos calcular o valor à pagar com frete ou não.

Para isso vamos utilizar a função Se, pois o valor será alterado de acordo com a caixa de seleção.

Clique na célula F7.

Digite a fórmula: =SE(A1=VERDADEIRO;F6+40;F6)

Explicando a fórmula:

Se a célula de vínculo da caixa de seleção (A1) for igual à Verdadeiro então some ao Subtotal (F6) quarenta reais; caso contrário me retorne apenas o subtotal (F6).

Obs: Quando a célula de vínculo da caixa, exibe Verdadeiro, indica que a mesma está selecionada, ou seja, a venda terá frete.

Veja a caixa está selecionada e foi acrescido quarenta reais ao valor à pagar.

 

Com a caixa desmarcada, o valor à pagar retorna apenas o subtotal.

 

Até a próxima dica.